Kernel panic

Es fing damit an, dass Uschi mich vorgestern gefragt hatte, openVPN auf meinem Rechner zu installieren, damit ich von meinem Rechner aus mein Programm auf seinem Mac laufen lassen kann. Ich hatte bis gestern noch keine Zeit gehabt, als er mich fragte, ob die Installation erfolgreich war. Gegen 18:00 habe ich also angefangen, mich darum zu kümmern, und habe festgestellt, dass seit mein Vorgänger die Arbeitsgruppe verlassen hat, kein Update gemacht wurde. Kann ich gleich machen, dachte ich. Als root mit su - einloggen, dann yum -y update. Es waren 144 davon in der Liste. Eine Meldung zum Entfernen und zur Neuinstallierung von Kernel wurde auch angegeben. Wenn yum das vorschlägt, kann es wohl nicht schaden, dachte ich mir naiv. Danach habe ich openVPN installiert und es irgendwie nach gegoogelten Anleitungen konfiguriert. Es war schon fast 20:00 und ich war mit Martin verabredet, daher habe ich mich ausgeloggt und Feierabend gemacht.

Heute Morgen angekommen, eingeloggt… Geht nicht. Ich dachte zuerst, ich hätte mich beim Eintippen vom Passwort vertippt, aber nach dem vierten Mal kann es nicht sein. Capslock war aus. Auf meinem Testrechner habe ich mit dem gleichen Passwort kein Problem gehabt. Und mit ssh konnte ich mich auf meinem Rechner einloggen. Merkwürdig. Vielleicht sollte ich den Rechner nach den vielen Updates von gestern neu starten? Tja, beim Hochfahren kam die Meldung:

Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-431.1.2.el6.i686 #1
Call Trace:
[] ? panic+0x6e/0x122
[] ? do_exit+0x741/0x750
[] ? do_group_exit+0x3c/0xa0
[] ? sys_exit_group+0x11/0x20
[] ? sysenter_do_call+0x12/0x28

Nicht nur der Kernel hat Panik bekommen. Mein IT-Kollege war schon um 08:30 mit anderen Aufgaben überlastet und hatte keine Zeit. Wie üblich.

Nach mehreren gezwungegen Neustarten habe ich gemerkt, dass ich mit ESC zum Boot-Menü gehen konnte, und dort waren drei Versionen von Scientific Linux vorhanden. Die erste führte zum Kernel panic. Mit der zweiten konnte ich meine Login-Daten angeben, aber nach einem scheinbaren Start meiner Session kam das Login-Fenster wieder. Mit der dritten und ältesten Version bekam ich nur einen schwarzen Bildschirm mit einem blinkenden Kursor. Nur mit der zweiten konnte ich mich von meinem Testrechner aus durch ssh einloggen.

Mit yum history undo xxx dachte ich, die Lösung gefunden zu haben. Aber jetzt sieht es so aus:

Kernel panic - not syncing: VFS: Unable to mount fs on unknown-block(0,0)

Ich kann mich nun gar nicht mehr ins Rechner anmelden.

Advertisements

Teile deine Meinung mit!

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s